Payslip Printing Error: The system cannot find the file specified.
Issue
Error: This system cannot find the file specified.
When: printing Payslips
Recently some Eclipse Payroll users have been experiencing this error when attempting to print Payslips from either the Payrun or Reports screens.
This issue affects all Payroll builds up to and including 650.
Note: I am reasonably sure this issue only affects Windows 10 (64 Bit) users.
Cause
Recently Adobe have updated the automatic installer that delivers the Acrobat Reader software. If this is run presently the it will deliver the (full) Acrobat DC or Acrobat Reader DC software instead by default. The full DC version is different from the cut down Acrobat Reader 32 software. The DC versions use ACROBAT.EXE for its executable. The Acrobat Reader 32 version uses ACRORD32.EXE as its executable. If the user or the Adobe Update service upgrades Acrobat presently the DC version of Acrobat will be dropped onto the system and Acrobat Reader will be removed.
Eclipse Payroll is hard coded to work with the ACRORD32.EXE executable. When it tries to launch this file to print the document it fails with the above error if the ACRORD32.EXE executable cannot be found. And if this occurs its likely the Adobe update service has run and replaced the Acrobat Reader software with the Acrobat DC or Acrobat Reader DC software (both use ACROBAT.EXE).
Fix
Fixed in Eclipse Payroll 660 onwards (due for release in mid October 2021). Changes have been made to remove any dependence on a particular PDF viewer. So long as some PDF viewer is installed it will work.
Workaround
The workaround is to uninstall Acrobat DC or Acrobat Reader DC and then reinstall the Acrobat Reader 32 software using a install setup that actually delivers the ACRORD32.EXE file. There does not appear to be a way to get this from Adobe itself anymore.So see links below.
Note also that the Acrobat Update Service that is delivered with the Acrobat software will continue to run (if not disabled) periodically and will probably end up upgrading the system back to the Acrobat DC software, therefore introducing the same defect again.
Links
Adobe Acrobat Reader version 10 setup can be found here:
\\ubsnas1\Install\Acrobat Reader\AdbeRdr1001_en_US.exe
Installation Notes
Be sure to first uninstall Acrobat DC or Acrobat Reader DC versions using Control Panel → Add Remove Programs. You do not HAVE to do this but there is a very high chance that the newer version will end up becoming the default PDF viewer at some point and so the problem will reappear (as soon as it becomes the default viewer it removes the ARCORD32.EXE file).
Note that it seems to be impossible to stop the later version from auto-reinstalling itself and thus reintroduce the problem.
So you may wish to explain to clients how do fix the problem (until the Fix release is available) and leave them with a copy of the Acrobat Reader Setup EXE.